资讯详情

Information for details

秉承以质量为核心,提升企业品牌商业价值是我们最根本的目的!

无线设备WiFi加密被破解有啥影响

阅读 · 发布时间2017-10-17 17:04:59·
多年来保护我们无线连接安全的 WPA2 加密协议日前被成功破解。比利时鲁汶大学的 Mathy Vanhoef 发现了 WPA2 加密协议的漏洞,并披露了实施攻击的详细细节。Mathy Vanhoef 计划将在 11 月 1 日举办的计算机和通信安全(CCS)2017 会议和 Black Hat 欧洲会议上发表这一研究成果。



  WPA2 被破解,全世界的 WiFi 设备都不安全了?

  在这一消息被披露之后,有些媒体认为,由于目前几乎所有的 WiFi 加密都使用了 WPA/WPA2 加密协议,这一协议被黑客破解之后,全世界的 WiFi 上网设备都不安全了。

  Mathy Vanhoef 称,这一漏洞名为“KRACK”,是“Key Reinstallation Attack”(密钥重安装攻击)的缩写。Mathy Vanhoef 表示,通过研发,其发现 WPA2 在四路握手(four-way handshake)时,允许拥有预共享密码的新设备加入网络。

  有中国黑客教父之称的 goodwell 对搜狐科技表示,这个 KRACK ATTACK 攻击应该是目前最取巧的针对 WPA/WPA2 的中间人攻击方法。这一攻击并不针对 WPA 加密本身,而是通过多次重播四次握手的信息3,来强制复位 client 本地保存的 WPA2 密钥,即把原来正确真实的 WPA 密码替换掉,不破解直接替换成全 0 密钥,这样就可以将受害者连到伪造的 AP 上,无需任何提示。再配合 SSLStrip 之类的工具做中间人,就圆满地实现了基于 WIFI 的无缝中间人攻击。

  goodwell 称,攻击者并不能通过这种攻击手段达到蹭网的目的。主要是影响客户端而非路由器。最冤的是 Linux 系统,其只有 wpa_supplicant,严格遵守 IEEE“不能重复使用密钥”的提醒,密钥用后即刻清零。也因为如此,其连接密钥就真的变成全“0”,造成了比其他设备严重得多的问题。

  Mathy Vanhoef 也确认,这种攻击对 Linux 和 Android 6.0 或更高版本是非常有破坏性的。这是因为 Android 和 Linux 可以被欺骗(重新)安装一个全零加密密钥。

  这种攻击并不能攻击 WiFi 路由器,而是在用户连接到路由器并正常使用后,攻击者切入进来,替换用户原来的连接,让其连到攻击者的路由器上去,从而达到数据挟持的目的。

  业界厂商声明将尽快发布补丁

  这一漏洞披露之后,微软称于 10 月 10 日发布安全补丁,使用 Windows Update 的客户可以自动或手动升级补丁,达到自动防卫的目的。

  Google 称,其已经了解到这一问题的存在,未来几周内会给任何受影响的设备打上补丁。

  而苹果也表示,已经证实 iOS、MacOS、WatchOS、TVOS 会受影响,在未来几周内会通过软件升级的形式提供修复补丁。

  Linksys/贝尔金称,已经了解到了 KRACK 漏洞的存在。安全团队正在确认这一漏洞的影响,会根据情况提供支持及升级。网件也称,已经为多款产品发布了修复补丁,公司也正在为其它产品开发相关补丁。用户可以在支持页面查询升级情况。

  KRACK 攻击原理致其影响程度有限

  尽管这一漏洞几乎影响了所有的 WiFi 上网设备。但专注无线安全的 RadioWar 创始人 SandMAN 对搜狐科技称,利用 KRACK 漏洞,对于近端攻击或者劫持信息的人来说,这个手法很好用。但这一攻击手法并无法批量对无线客户端进行攻击,只能一个一个地攻击客户端,使用户在不知情的情况下连接到伪造的 AP。因此,其攻击效率很低下。对动辄数以亿计的无线设备来讲,个人中招的机率非常低。

  SandMAN 称,KRACK 攻击的意义在于大型 WLAN 或者是特定的核心目标。另外,现有的 WiFi 防御对这种攻击也是可以做到预先防御的,因为攻击的套路本身是不会改变的。

  提高 WiFi 设备安全要做这样的功课

  要避免受到 KRACK 攻击,用户需要做如下功课:

  1. 及时更新无线路由器、手机,智能硬件等所有使用 WPA2 无线认证客户端的软件版本(在有补丁的前提下)。

  2. 有条件的企业及个人请合理部署 WIPS,及时监测合法 WiFi 区域内的恶意钓鱼 WiFi,并加以阻断干扰,使其恶意 WiFi 无法正常工作。(WIPS 的重要性)

  3. 无线通信连接使用 VPN 加密隧道及强制 SSL 规避流量劫持与中间人攻击造成的信息泄漏。

  4. 国标 WAPI 无线认证暂不受该漏洞影响。